<!DOCTYPE html>
<html lang="en-US">
    <head>
        <meta charset="UTF-8">
        <meta name="viewport" content="width=device-width, initial-scale=1.0, maximum-scale=1.0, user-scalable=no" />
        <title>Chex Quest HD Launches for Free on PC - Hardcore Gamer</title>
        <link rel="profile" href="http://gmpg.org/xfn/11">
        <link rel="pingback" href="https://hardcoregamer.com/xmlrpc.php">
        <link rel="shortcut icon" href="https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/favicon.png" />
        <link href='https://fonts.googleapis.com/css?family=Montserrat' rel='stylesheet' type='text/css'>
        <script src="//code.jquery.com/jquery-1.11.0.min.js"></script>
        <script src="//code.jquery.com/jquery-migrate-1.2.1.min.js"></script>
<!--test-->
		<script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
		<script>
		  (adsbygoogle = window.adsbygoogle || []).push({
			google_ad_client: "ca-pub-9617772992011547",
			enable_page_level_ads: true
		  });
		</script>
<!--test-->
        
	<!-- This site is optimized with the Yoast SEO plugin v14.0.4 - https://yoast.com/wordpress/plugins/seo/ -->
	<meta name="robots" content="index, follow" />
	<meta name="googlebot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<meta name="bingbot" content="index, follow, max-snippet:-1, max-image-preview:large, max-video-preview:-1" />
	<link rel="canonical" href="https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/" />
	<meta property="og:locale" content="en_US" />
	<meta property="og:type" content="article" />
	<meta property="og:title" content="Chex Quest HD Launches for Free on PC - Hardcore Gamer" />
	<meta property="og:description" content="Chex Quest is back! Years after kids first received copies of Chex Quest in their cereal boxes, an upgraded version is available for everyone on Steam. Chex Quest HD switches out the original engine and graphics for something more modern. The Flemoids and alien landscapes are all rendered in 3D this time. The game supports [&hellip;]" />
	<meta property="og:url" content="https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/" />
	<meta property="og:site_name" content="Hardcore Gamer" />
	<meta property="article:published_time" content="2020-05-19T00:26:32+00:00" />
	<meta property="og:image" content="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/chexquesthd.jpg" />
	<meta property="og:image:width" content="698" />
	<meta property="og:image:height" content="289" />
	<meta name="twitter:card" content="summary_large_image" />
	<script type="application/ld+json" class="yoast-schema-graph">{"@context":"https://schema.org","@graph":[{"@type":"WebSite","@id":"https://hardcoregamer.com/#website","url":"https://hardcoregamer.com/","name":"Hardcore Gamer","description":"","potentialAction":[{"@type":"SearchAction","target":"https://hardcoregamer.com/?s={search_term_string}","query-input":"required name=search_term_string"}],"inLanguage":"en-US"},{"@type":"ImageObject","@id":"https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/#primaryimage","inLanguage":"en-US","url":"https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/chexquesthd.jpg","width":698,"height":289},{"@type":"WebPage","@id":"https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/#webpage","url":"https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/","name":"Chex Quest HD Launches for Free on PC - Hardcore Gamer","isPartOf":{"@id":"https://hardcoregamer.com/#website"},"primaryImageOfPage":{"@id":"https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/#primaryimage"},"datePublished":"2020-05-19T00:26:32+00:00","dateModified":"2020-05-19T00:26:32+00:00","author":{"@id":"https://hardcoregamer.com/#/schema/person/1a2e8475c4f55ec2484bad1b8569b4fe"},"inLanguage":"en-US","potentialAction":[{"@type":"ReadAction","target":["https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/"]}]},{"@type":["Person"],"@id":"https://hardcoregamer.com/#/schema/person/1a2e8475c4f55ec2484bad1b8569b4fe","name":"Marcus Estrada","description":"Video games, horror films, and Japanese food are just some of my favorite things."}]}</script>
	<!-- / Yoast SEO plugin. -->


<link rel='dns-prefetch' href='//fonts.googleapis.com' />
<link rel='dns-prefetch' href='//s.w.org' />
<link rel='dns-prefetch' href='//hardcore-gamer.s3.amazonaws.com' />
<link rel="alternate" type="application/rss+xml" title="Hardcore Gamer &raquo; Feed" href="https://hardcoregamer.com/feed/" />
<link rel="alternate" type="application/rss+xml" title="Hardcore Gamer &raquo; Comments Feed" href="https://hardcoregamer.com/comments/feed/" />
<link rel="alternate" type="application/rss+xml" title="Hardcore Gamer &raquo; Chex Quest HD Launches for Free on PC Comments Feed" href="https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/feed/" />
		<script type="text/javascript">
			window._wpemojiSettings = {"baseUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/72x72\/","ext":".png","svgUrl":"https:\/\/s.w.org\/images\/core\/emoji\/12.0.0-1\/svg\/","svgExt":".svg","source":{"concatemoji":"https:\/\/hardcoregamer.com\/wp-includes\/js\/wp-emoji-release.min.js?ver=24c01401bf29ed77f4ac0a6c60102b5a"}};
			/*! This file is auto-generated */
			!function(e,a,t){var r,n,o,i,p=a.createElement("canvas"),s=p.getContext&&p.getContext("2d");function c(e,t){var a=String.fromCharCode;s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,e),0,0);var r=p.toDataURL();return s.clearRect(0,0,p.width,p.height),s.fillText(a.apply(this,t),0,0),r===p.toDataURL()}function l(e){if(!s||!s.fillText)return!1;switch(s.textBaseline="top",s.font="600 32px Arial",e){case"flag":return!c([127987,65039,8205,9895,65039],[127987,65039,8203,9895,65039])&&(!c([55356,56826,55356,56819],[55356,56826,8203,55356,56819])&&!c([55356,57332,56128,56423,56128,56418,56128,56421,56128,56430,56128,56423,56128,56447],[55356,57332,8203,56128,56423,8203,56128,56418,8203,56128,56421,8203,56128,56430,8203,56128,56423,8203,56128,56447]));case"emoji":return!c([55357,56424,55356,57342,8205,55358,56605,8205,55357,56424,55356,57340],[55357,56424,55356,57342,8203,55358,56605,8203,55357,56424,55356,57340])}return!1}function d(e){var t=a.createElement("script");t.src=e,t.defer=t.type="text/javascript",a.getElementsByTagName("head")[0].appendChild(t)}for(i=Array("flag","emoji"),t.supports={everything:!0,everythingExceptFlag:!0},o=0;o<i.length;o++)t.supports[i[o]]=l(i[o]),t.supports.everything=t.supports.everything&&t.supports[i[o]],"flag"!==i[o]&&(t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&t.supports[i[o]]);t.supports.everythingExceptFlag=t.supports.everythingExceptFlag&&!t.supports.flag,t.DOMReady=!1,t.readyCallback=function(){t.DOMReady=!0},t.supports.everything||(n=function(){t.readyCallback()},a.addEventListener?(a.addEventListener("DOMContentLoaded",n,!1),e.addEventListener("load",n,!1)):(e.attachEvent("onload",n),a.attachEvent("onreadystatechange",function(){"complete"===a.readyState&&t.readyCallback()})),(r=t.source||{}).concatemoji?d(r.concatemoji):r.wpemoji&&r.twemoji&&(d(r.twemoji),d(r.wpemoji)))}(window,document,window._wpemojiSettings);
		</script>
		<style type="text/css">
img.wp-smiley,
img.emoji {
	display: inline !important;
	border: none !important;
	box-shadow: none !important;
	height: 1em !important;
	width: 1em !important;
	margin: 0 .07em !important;
	vertical-align: -0.1em !important;
	background: none !important;
	padding: 0 !important;
}
</style>
	<link rel='stylesheet' id='searchandfilter-css'  href='https://hardcoregamer.com/wp-content/plugins/search-filter/style.css?ver=1' type='text/css' media='all' />
<link rel='stylesheet' id='st-widget-css'  href='https://hardcoregamer.com/wp-content/plugins/share-this/css/style.css?ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='googlefonts-css'  href='https://fonts.googleapis.com/css?family=Roboto+Slab:100,300,400,700|Montserrat:400,700|Muli|Arimo:400,400italic,700,700italic&subset=latin' type='text/css' media='all' />
<link rel='stylesheet' id='blain-fonts-css'  href='//fonts.googleapis.com/css?family=Source+Sans+Pro%3A400%2C600%2C700&#038;ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='blain-basic-style-css'  href='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/style.css?ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='blain-layout-css'  href='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/css/layouts/sidebar-content.css?ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='blain-bootstrap-style-css'  href='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/css/bootstrap.min.css?ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='blain-main-style-css'  href='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/css/main.css?ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='blain-mobile-style-css'  href='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/css/mobile.css?ver=24c01401bf29ed77f4ac0a6c60102b5a' type='text/css' media='all' />
<link rel='stylesheet' id='lightbox-style-css'  href='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/css/lightbox.css?ver=20120202' type='text/css' media='all' />
<link rel='stylesheet' id='slb_core-css'  href='https://hardcoregamer.com/wp-content/plugins/simple-lightbox/client/css/app.css?ver=2.8.1' type='text/css' media='all' />
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/jquery/jquery.js?ver=1.12.4-wp'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/jquery/jquery-migrate.min.js?ver=1.4.1'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/plugins/wp-featured-content-slider/scripts/jquery.cycle.all.2.72.js?ver=1.3'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/jquery.timeago.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/collapse.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/superfish.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/respond.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/bootstrap.min.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/lightbox.js?ver=20120202'></script>
<link rel='https://api.w.org/' href='https://hardcoregamer.com/wp-json/' />
<link rel="EditURI" type="application/rsd+xml" title="RSD" href="https://hardcoregamer.com/xmlrpc.php?rsd" />
<link rel="wlwmanifest" type="application/wlwmanifest+xml" href="https://hardcoregamer.com/wp-includes/wlwmanifest.xml" /> 

<link rel='shortlink' href='https://hardcoregamer.com/?p=378445' />
<link rel="alternate" type="application/json+oembed" href="https://hardcoregamer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhardcoregamer.com%2F2020%2F05%2F18%2Fchex-quest-hd-launches-for-free-on-pc%2F378445%2F" />
<link rel="alternate" type="text/xml+oembed" href="https://hardcoregamer.com/wp-json/oembed/1.0/embed?url=https%3A%2F%2Fhardcoregamer.com%2F2020%2F05%2F18%2Fchex-quest-hd-launches-for-free-on-pc%2F378445%2F&#038;format=xml" />
<script type="text/javascript">var ajaxurl = "https://hardcoregamer.com/wp-admin/admin-ajax.php";</script><script charset="utf-8" type="text/javascript">var switchTo5x=true;</script>
<script charset="utf-8" type="text/javascript" id="st_insights_js" src="https://ws.sharethis.com/button/buttons.js?publisher=wp.a959b4c7-30b8-432e-ad1b-dc467485703b&amp;product=sharethis-wordpress"></script>
<script charset="utf-8" type="text/javascript">stLight.options({"publisher":"wp.a959b4c7-30b8-432e-ad1b-dc467485703b","doNotCopy":true,"hashAddressBar":false,"doNotHash":true});var st_type="wordpress4.9.8";</script>
<style></style><link rel="icon" href="https://hardcore-gamer.s3.amazonaws.com/uploads/2017/08/cropped-HGTesting3-32x32.png" sizes="32x32" />
<link rel="icon" href="https://hardcore-gamer.s3.amazonaws.com/uploads/2017/08/cropped-HGTesting3-192x192.png" sizes="192x192" />
<link rel="apple-touch-icon" href="https://hardcore-gamer.s3.amazonaws.com/uploads/2017/08/cropped-HGTesting3-180x180.png" />
<meta name="msapplication-TileImage" content="https://hardcore-gamer.s3.amazonaws.com/uploads/2017/08/cropped-HGTesting3-270x270.png" />
		<style type="text/css" id="wp-custom-css">
			#content {
    padding-bottom: 350px;
}		</style>
		    </head>
    	
	
    <body id="hcg-body" class="post-template-default single single-post postid-378445 single-format-standard banner_bg_no news group-blog">
                <header  class="site-header row container" role="banner">
            <div id="masthead" >
                <div id="inner-masthead">

                    <div class="nav-wrapper container">
                        <div class="site-branding col-sm-3 col-xs-6">
                                                            <h1 class="site-title logo-container"><a href="https://hardcoregamer.com/" title="Hardcore Gamer" rel="home">
                                        <img class='main_logo' src='https://hardcore-gamer.s3.amazonaws.com/uploads/2017/08/HGMainSiteFont3c.png' title='Hardcore Gamer'></a></h1>                                    </div>

                                    <nav id="site-navigation" class="navbar navbar-default main-navigation col-md-7 col-sm-8 " role="navigation">

                                        <div class="navbar-header">
                                            <button type="button" class="navbar-toggle" data-toggle="collapse" data-target=".navbar-ex1-collapse">
                                                <span class="sr-only">Toggle navigation</span>
                                                <span class="icon-bar"></span>
                                                <span class="icon-bar"></span>
                                                <span class="icon-bar"></span>
                                            </button>
                                        </div>


                                        <div class="collapse navbar-collapse navbar-ex1-collapse"><ul id="menu-header-menu" class="nav navbar-nav"><li id="menu-item-120520" class="menu-item menu-item-type-custom menu-item-object-custom menu-item-120520"><a title="Games" href="/games">Games</a></li>
<li id="menu-item-104104" class="menu-item menu-item-type-taxonomy menu-item-object-category current-post-ancestor current-menu-parent current-post-parent menu-item-104104"><a title="News" href="https://hardcoregamer.com/category/news/">News</a></li>
<li id="menu-item-104106" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-104106"><a title="Reviews" href="https://hardcoregamer.com/category/reviews/">Reviews</a></li>
<li id="menu-item-104108" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-104108"><a title="Previews" href="https://hardcoregamer.com/category/previews/">Previews</a></li>
<li id="menu-item-106941" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-has-children menu-item-106941 dropdown"><a title="Features" href="https://hardcoregamer.com/category/features/" data-toggle="dropdown" class="dropdown-toggle">Features <span class="caret"></span></a>
<ul role="menu" class=" dropdown-menu">
	<li id="menu-item-107453" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107453"><a title="Casual Corner" href="https://hardcoregamer.com/category/features/casual-corner/">Casual Corner</a></li>
	<li id="menu-item-236919" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-236919"><a title="Checking the Score" href="https://hardcoregamer.com/category/features/checking-the-score/">Checking the Score</a></li>
	<li id="menu-item-107454" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107454"><a title="Collector&#039;s Cabinet" href="https://hardcoregamer.com/category/features/collectors-cabinet/">Collector&#8217;s Cabinet</a></li>
	<li id="menu-item-232535" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232535"><a title="Fatal Flaws" href="https://hardcoregamer.com/category/features/fatal-flaws/">Fatal Flaws</a></li>
	<li id="menu-item-268617" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-268617"><a title="Gaming with my Girlfriend" href="https://hardcoregamer.com/category/features/gaming-with-my-girlfriend/">Gaming with my Girlfriend</a></li>
	<li id="menu-item-107456" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107456"><a title="Graveyard" href="https://hardcoregamer.com/category/features/graveyard/">Graveyard</a></li>
	<li id="menu-item-107459" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107459"><a title="Interviews" href="https://hardcoregamer.com/category/features/interviews/">Interviews</a></li>
	<li id="menu-item-232536" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-232536"><a title="Lowered Expectations" href="https://hardcoregamer.com/category/features/lowered-expectations/">Lowered Expectations</a></li>
	<li id="menu-item-268618" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-268618"><a title="Member?" href="https://hardcoregamer.com/category/features/member/">Member?</a></li>
	<li id="menu-item-107462" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107462"><a title="Pocket Power" href="https://hardcoregamer.com/category/features/pocket-power/">Pocket Power</a></li>
	<li id="menu-item-178769" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-178769"><a title="Screenshot Saturday" href="https://hardcoregamer.com/category/features/screenshot-saturday/">Screenshot Saturday</a></li>
	<li id="menu-item-107464" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-107464"><a title="Toplist" href="https://hardcoregamer.com/category/features/toplist/">Toplist</a></li>
</ul>
</li>
<li id="menu-item-264600" class="menu-item menu-item-type-taxonomy menu-item-object-category menu-item-264600"><a title="Videos" href="https://hardcoregamer.com/category/videos/">Videos</a></li>
</ul></div>

                                    </nav><!-- #site-navigation --> 
                                    <div>
                                        <span class="search_button col-sm-1 visible-sm visible-xs" id="toggle-search"><i class="social-icon icon-search"></i></span>
                                    </div>
                                    <div id="social-icons" class="col-md-2 visible-lg visible-md">
                                        <span class="search_button"><i class="social-icon icon-search"></i></span>
                                                                                    <a target='_blank' href="https://www.facebook.com/pages/Hardcore-Gamer/350356301684225" title="Facebook" ><i class="social-icon icon-facebook"></i></a>
                                                                                                                            <a target='_blank' href="http://twitter.com/HardcoreGamer" title="Twitter" ><i class="social-icon icon-twitter"></i></a>
                                                                                                                            <a target='_blank' href="https://www.youtube.com/user/HardcoreGamerVideo" title="YouTube" ><i class="social-icon icon-youtube"></i></a>
                                                                                                                                                                    <a target='_blank' href="http://hardcoregamer.tumblr.com/" title="Tumblr" ><i class="social-icon icon-tumblr"></i></a>
                                         
                                                                                    <a target='_blank' href="https://hardcoregamer.com/feed/" title="RSS Feeds" ><i class="social-icon icon-rss"></i></a>
                                                                                                                                                                                                                                                                                    </div>

                                    </div>		
                                    </div>
                                    </div>

                                    <div id="search-container-wrapper container">
                                        <div id="inner-search-container">
                                            <div class="search-container">
                                                <form role="search" method="get" class="row search-form" action="https://hardcoregamer.com/">
	<label>
		<span class="screen-reader-text">Search for:</span>
		<input type="search" class="search-field" placeholder="Search &hellip;" value="" name="s">
	</label>
	<input type="submit" class="search-submit" value="Search">
</form>
                                            </div>
                                        </div>
                                    </div>   
                                    </header><!-- #masthead -->

                                    <div class="custom-grey-bar"></div>
                                    
                                    <div id="page" class="hfeed site">

                                                                                    <div id="single-header-container" class="row container visible-lg">		 
                                                <div id="single-header-thumbs" class="container row visible-lg">
                                                                                                                                                                <div class="single-header-thumb col-sm-2">
                                                            <a href="https://hardcoregamer.com/2020/05/18/mini-gaming-laptop-gpd-win-max-seeing-huge-success-on-indiegogo/378448/">
                                                                <img width="330" height="218" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/gpdwinmaxpromo-330x218.jpg" class="attachment-header-thumb size-header-thumb wp-post-image" alt="" />		
                                                            </a>
                                                            <div class="transpBlack">
                                                                <a href="https://hardcoregamer.com/2020/05/18/mini-gaming-laptop-gpd-win-max-seeing-huge-success-on-indiegogo/378448/">
                                                                    <h3 class="post-title">Mini Gaming Laptop GPD Win Max Seeing Huge Success on Indiegogo</h3>
                                                                </a>
                                                            </div>
                                                        </div>
                                                                                                            <div class="single-header-thumb col-sm-2">
                                                            <a href="https://hardcoregamer.com/2020/05/18/minecraft-breaks-another-major-number-with-over-200-million-sold/378436/">
                                                                <img width="330" height="218" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/MinecraftFeature-330x218.jpg" class="attachment-header-thumb size-header-thumb wp-post-image" alt="" />		
                                                            </a>
                                                            <div class="transpBlack">
                                                                <a href="https://hardcoregamer.com/2020/05/18/minecraft-breaks-another-major-number-with-over-200-million-sold/378436/">
                                                                    <h3 class="post-title">Minecraft Breaks Another Major Number with Over 200 Million Sold</h3>
                                                                </a>
                                                            </div>
                                                        </div>
                                                                                                            <div class="single-header-thumb col-sm-2">
                                                            <a href="https://hardcoregamer.com/2020/05/18/unleash-the-power-of-friendship-in-mortal-kombat-11-aftermath/378430/">
                                                                <img width="330" height="218" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/Mortal-Kombat-11-Aftermath-330x218.jpg" class="attachment-header-thumb size-header-thumb wp-post-image" alt="" />		
                                                            </a>
                                                            <div class="transpBlack">
                                                                <a href="https://hardcoregamer.com/2020/05/18/unleash-the-power-of-friendship-in-mortal-kombat-11-aftermath/378430/">
                                                                    <h3 class="post-title">Unleash the Power of Friendship in Mortal Kombat 11: Aftermath</h3>
                                                                </a>
                                                            </div>
                                                        </div>
                                                                                                            <div class="single-header-thumb col-sm-2">
                                                            <a href="https://hardcoregamer.com/2020/05/16/pokemon-go-incense-box-available-now-for-special-event/378383/">
                                                                <img width="330" height="218" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2017/12/pokemongo-1-330x218.png" class="attachment-header-thumb size-header-thumb wp-post-image" alt="" />		
                                                            </a>
                                                            <div class="transpBlack">
                                                                <a href="https://hardcoregamer.com/2020/05/16/pokemon-go-incense-box-available-now-for-special-event/378383/">
                                                                    <h3 class="post-title">Pokemon Go Incense Box Available now for Special Event</h3>
                                                                </a>
                                                            </div>
                                                        </div>
                                                                                                            <div class="single-header-thumb col-sm-2">
                                                            <a href="https://hardcoregamer.com/2020/05/16/game-pass-adds-alan-wake-next-week-on-xbox-and-pc/378377/">
                                                                <img width="330" height="218" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2016/03/AlanWake-330x218.jpg" class="attachment-header-thumb size-header-thumb wp-post-image" alt="" />		
                                                            </a>
                                                            <div class="transpBlack">
                                                                <a href="https://hardcoregamer.com/2020/05/16/game-pass-adds-alan-wake-next-week-on-xbox-and-pc/378377/">
                                                                    <h3 class="post-title">Game Pass Adds Alan Wake Next Week on Xbox One, PC</h3>
                                                                </a>
                                                            </div>
                                                        </div>
                                                                                                            <div class="single-header-thumb col-sm-2">
                                                            <a href="https://hardcoregamer.com/2020/05/16/terrarias-long-road-to-completion-is-done-with-1-4-journeys-end-update/378363/">
                                                                <img width="330" height="218" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/TerrariaFeature-330x218.jpg" class="attachment-header-thumb size-header-thumb wp-post-image" alt="" />		
                                                            </a>
                                                            <div class="transpBlack">
                                                                <a href="https://hardcoregamer.com/2020/05/16/terrarias-long-road-to-completion-is-done-with-1-4-journeys-end-update/378363/">
                                                                    <h3 class="post-title">Terraria&#8217;s Long Road to Completion is Done with 1.4 Journey&#8217;s End Update</h3>
                                                                </a>
                                                            </div>
                                                        </div>
                                                                                                                                                        </div>
                                            </div>

                                        
                                        
                                            <div class="row container wide-ad">
                                                <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle" style="display:block" data-ad-client="ca-pub-9617772992011547" data-ad-slot="9163418630" data-ad-format="auto" data-full-width-responsive="true"></ins>

<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>                                            </div>
                                        <div id="content" class="site-content row container">


	<div id="primary" class="content-area col-md-9">
		<main id="main" class="site-main" role="main">

		
			
<article id="post-378445" class="post-378445 post type-post status-publish format-standard has-post-thumbnail hentry category-news tag-chex-quest-hd news">
	<header class="entry-header">
	
<div class="featured-image-single"> <img width="698" height="289" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/chexquesthd.jpg" class="attachment-single-feat size-single-feat wp-post-image" alt="" srcset="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/chexquesthd.jpg 698w, https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/chexquesthd-570x236.jpg 570w" sizes="(max-width: 698px) 100vw, 698px" /></div>
		<h1 class="entry-title">Chex Quest HD Launches for Free on PC</h1>

		<div class="entry-meta">
								<span>By <a href="https://hardcoregamer.com/author/marcus-estrada/" rel="author">
				Marcus Estrada on May 18, 2020</a></span>
		</div><!-- .entry-meta -->
	</header><!-- .entry-header -->

	<div class="entry-content">

		<p class="no-break"><span st_url='https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/' st_title='Chex Quest HD Launches for Free on PC' class='st_sharethis_large'></span><span st_url='https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/' st_title='Chex Quest HD Launches for Free on PC' class='st_googleplus_large'></span><span st_url='https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/' st_title='Chex Quest HD Launches for Free on PC' class='st_reddit_large'></span><span class='st_stumbleupon_large' st_url='https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/' st_title='Chex Quest HD Launches for Free on PC'></span><span st_via='HardcoreGamer' st_username='HardcoreGamer' st_url='https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/' st_title='Chex Quest HD Launches for Free on PC' class='st_twitter_large'></span><span st_url='https://hardcoregamer.com/2020/05/18/chex-quest-hd-launches-for-free-on-pc/378445/' st_title='Chex Quest HD Launches for Free on PC' class='st_facebook_large'></span></p><p>Chex Quest is back! Years after kids first received copies of Chex Quest in their cereal boxes, an upgraded version is available for everyone on Steam.</p>
<p>Chex Quest HD switches out the original engine and graphics for something more modern. The Flemoids and alien landscapes are all rendered in 3D this time. The game supports single player and local co-op.</p>
<p>Folks hoping to rekindle their nostalgia can do so for free. <a href="https://store.steampowered.com/app/804270/Chex_Quest_HD/" target="_blank" rel="noopener noreferrer">Chex Quest HD</a> is available on Steam at no cost, though it only runs on Windows.</p>
<div class="wsNHzuDR" style="clear:both;float:left;width:100%;margin:0 0 20px 0;"><script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<ins class="adsbygoogle"
     style="display:block; text-align:center;"
     data-ad-layout="in-article"
     data-ad-format="fluid"
     data-ad-client="ca-pub-9617772992011547"
     data-ad-slot="7101628117"></ins>
<script>
     (adsbygoogle = window.adsbygoogle || []).push({});
</script></div>		
	</div><!-- .entry-content -->

	
</article><!-- #post-## -->

				<nav role="navigation" id="nav-below" class="post-navigation">
		<h1 class="screen-reader-text">Post navigation</h1>

	
		<div class="nav-previous"><a href="https://hardcoregamer.com/2020/05/18/minecraft-breaks-another-major-number-with-over-200-million-sold/378436/" rel="prev"><span class="meta-nav">&larr;</span> Minecraft Breaks Another Major Number with Over 200 Million Sold</a></div>		<div class="nav-next"><a href="https://hardcoregamer.com/2020/05/18/mini-gaming-laptop-gpd-win-max-seeing-huge-success-on-indiegogo/378448/" rel="next">Mini Gaming Laptop GPD Win Max Seeing Huge Success on Indiegogo <span class="meta-nav">&rarr;</span></a></div>
	
	</nav><!-- #nav-below -->
	
			
<div id="disqus_thread"></div>
		
		
		</main><!-- #main -->
	</div><!-- #primary -->

<div id="secondary" class="widget-area col-md-3 visible-md visible-lg" role="complementary">
        <div class="widget_text">
                    <!-- ROS Sidebar Ad -->
            <div class="sidebar-ad">		
                <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Above the Fold 600x300 Sidebar Ad - All Pages -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:600px"
     data-ad-client="ca-pub-9617772992011547"
     data-ad-slot="8070902302"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>            </div>

            </div>


    
    <aside id="dpe_fp_widget-2" class="widget widget_dpe_fp_widget"><h1 class="widget-title">Latest Reviews</h1>	<ul id="review-widget" class="dpe-flexible-posts"> <!-- HCG Reviews -->
			<li id="post-378385" class="post-378385 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-80s-overdrive reviews">
			<a href="https://hardcoregamer.com/2020/05/18/review-80s-overdrive/378385/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/80sOverdriveCityFeatured-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: &#8217;80s Overdrive</h4>
			</a>
		</li>
			<li id="post-378094" class="post-378094 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-hatsune-miku-project-diva-mega-mix reviews">
			<a href="https://hardcoregamer.com/2020/05/14/review-hatsune-miku-project-diva-mega-mix/378094/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/HatsuneMikuRHeader1-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: Hatsune Miku: Project DIVA Mega Mix</h4>
			</a>
		</li>
			<li id="post-378208" class="post-378208 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-skydance-interactive tag-the-walking-dead-saints-sinners tag-twd reviews">
			<a href="https://hardcoregamer.com/2020/05/14/review-the-walking-dead-saints-sinners/378208/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/twd4-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: The Walking Dead: Saints &#038; Sinners</h4>
			</a>
		</li>
			<li id="post-377630" class="post-377630 post type-post status-publish format-standard has-post-thumbnail hentry category-hardware category-reviews tag-jbl-quantum-one hardware reviews">
			<a href="https://hardcoregamer.com/2020/05/13/review-jbl-quantum-one/377630/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/quantumone-1-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: JBL Quantum One</h4>
			</a>
		</li>
			<li id="post-377967" class="post-377967 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-the-wonderful-101-remastered reviews">
			<a href="https://hardcoregamer.com/2020/05/11/review-the-wonderful-101-remastered/377967/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/Wonderful101FeaturedCross-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: The Wonderful 101: Remastered</h4>
			</a>
		</li>
			<li id="post-377862" class="post-377862 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-infinite-beyond-the-mind reviews">
			<a href="https://hardcoregamer.com/2020/05/10/review-infinite-beyond-the-mind/377862/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/04/FeaturedReviewImage-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: Infinite &#8211; Beyond the Mind</h4>
			</a>
		</li>
			<li id="post-377631" class="post-377631 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-jay-and-silent-bob-mall-brawl reviews">
			<a href="https://hardcoregamer.com/2020/05/07/review-jay-and-silent-bob-mall-brawl/377631/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/05/mallbrawl-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: Jay and Silent Bob: Mall Brawl</h4>
			</a>
		</li>
			<li id="post-377175" class="post-377175 post type-post status-publish format-standard has-post-thumbnail hentry category-hardware category-reviews tag-asus tag-custom-build tag-gaming-pc tag-gtx-2080-super tag-intel tag-maingear-vybe tag-maingear-vybe-stage-4-gaming-desktop tag-rtx hardware reviews">
			<a href="https://hardcoregamer.com/2020/05/01/review-maingear-vybe-stage-4-gaming-desktop/377175/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/04/8-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: MAINGEAR VYBE Stage 4 Gaming Desktop</h4>
			</a>
		</li>
			<li id="post-377125" class="post-377125 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-illfonic tag-predator-hunting-grounds reviews">
			<a href="https://hardcoregamer.com/2020/04/30/review-predator-hunting-grounds/377125/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/04/Predator-Hunting-Grounds-Header-1-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: Predator: Hunting Grounds</h4>
			</a>
		</li>
			<li id="post-377079" class="post-377079 post type-post status-publish format-standard has-post-thumbnail hentry category-reviews tag-2k tag-firaxis-games tag-rts tag-xcom-chimera-squad reviews">
			<a href="https://hardcoregamer.com/2020/04/29/review-xcom-chimera-squad/377079/">
				<img width="100" height="68" src="https://hardcore-gamer.s3.amazonaws.com/uploads/2020/04/XCOM-Chimera-Squad-Verges-Psionics-100x68.jpg" class="attachment-thumbnail size-thumbnail wp-post-image" alt="" />				<h4 class="title">Review: XCOM: Chimera Squad</h4>
			</a>
		</li>
		<div class="see-all">
		<a href="https://hardcoregamer.com/category/reviews/">See All Reviews</a>
	</div>
	</ul><!-- .dpe-flexible-posts -->
</aside>
    <aside class="widget widget_text">
        <div class="widget_text">
            	
                <div class="google-sidebar-ad">
                    <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Below the Fold Sidebar - All Pages -->
<ins class="adsbygoogle"
     style="display:inline-block;width:300px;height:250px"
     data-ad-client="ca-pub-9617772992011547"
     data-ad-slot="4593618231"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>                </div>
                    </div>
    </aside>
</div><!-- #secondary -->

</div><!-- #content -->
</div><!-- #page -->

<footer class="site-footer" role="contentinfo">

    <div id="footer-container" class="container">

        <div class="col-md-4 col-sm-12">
            <span>&copy; 2020 Hardcore Gamer LLC. All rights reserved.</span>
        </div><!-- .site-info -->

        <div class="col-md-6 col-sm-12">
            <div class="menu-footer-menu-container"><ul id="menu-footer-menu" class="menu"><li id="menu-item-104118" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104118"><a href="https://hardcoregamer.com/about/">About</a></li>
<li id="menu-item-104120" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104120"><a href="https://hardcoregamer.com/staff/">Staff</a></li>
<li id="menu-item-104119" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104119"><a href="https://hardcoregamer.com/contact/">Contact</a></li>
<li id="menu-item-104117" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-104117"><a href="https://hardcoregamer.com/write-with-us/">Write With Us</a></li>
<li id="menu-item-117306" class="menu-item menu-item-type-post_type menu-item-object-page menu-item-117306"><a href="https://hardcoregamer.com/privacy-policy/">Privacy Policy</a></li>
</ul></div>        </div>   

        <div id="" class="col-md-4 col-sm-12">

        </div>

    </div>

    <div class="row container wide-ad">
        <style>
            .responsive-ad { width: 300px; height: 50px; margin-left:10px; margin-right:10px; }
            @media(min-width: 500px) { .responsive-ad { width: 468px; height: 60px; } }
            @media(min-width: 800px) { .responsive-ad { width: 728px; height: 90px; } }
        </style>

                    <script async src="//pagead2.googlesyndication.com/pagead/js/adsbygoogle.js"></script>
<!-- Below the Fold Responsive Banner Ad - All Pages -->
<ins class="adsbygoogle"
     style="display:block"
     data-ad-client="ca-pub-9617772992011547"
     data-ad-slot="2215955336"
     data-ad-format="auto"></ins>
<script>
(adsbygoogle = window.adsbygoogle || []).push({});
</script>            </div>

</footer><!-- #colophon -->


<script type="text/javascript">
    $(document).ready(function () {
        $(".search_button").click(function () {
            $(".search-container").addClass("search-active");
        });

        $('.dropdown-toggle').removeAttr("data-toggle")

        "Reviews".replace('Reviews', '');

    });
</script>

<!-- Quantcast Tag -->
<script type="text/javascript">
	var _qevents = _qevents || [];

	(function() {
		var elem = document.createElement('script');
		elem.src = (document.location.protocol == "https:" ? "https://secure" : "http://edge") + ".quantserve.com/quant.js";
		elem.async = true;
		elem.type = "text/javascript";
		var scpt = document.getElementsByTagName('script')[0];
		scpt.parentNode.insertBefore(elem, scpt);
	})();

	_qevents.push({
		qacct:"p-yXEv-78vAMKAb"
	});
	</script>

	<noscript>
	<div style="display:none;">
		<img src="//pixel.quantserve.com/pixel/p-yXEv-78vAMKAb.gif" border="0" height="1" width="1" alt="Quantcast"/>
	</div>
</noscript>
<!-- End Quantcast tag -->

<!-- Google Analytics 
<script>
    (function (i, s, o, g, r, a, m) {
        i['GoogleAnalyticsObject'] = r;
        i[r] = i[r] || function () {
            (i[r].q = i[r].q || []).push(arguments)
        }, i[r].l = 1 * new Date();
        a = s.createElement(o),
                m = s.getElementsByTagName(o)[0];
        a.async = 1;
        a.src = g;
        m.parentNode.insertBefore(a, m)
    })(window, document, 'script', '//www.google-analytics.com/analytics.js', 'ga');

    ga('create', 'UA-54884992-1', 'auto');
    ga('send', 'pageview');

</script>-->
<!-- End Google Analytics -->

<!--script type="text/javascript">
    var vglnk = {key: 'a2f555d73c8beff4b3a122f148da2fb3'};

    (function (d, t) {
        var s = d.createElement(t);
        s.type = 'text/javascript';
        s.async = true;
        s.src = '//cdn.viglink.com/api/vglnk.js';
        var r = d.getElementsByTagName(t)[0];
        r.parentNode.insertBefore(s, r);
    }(document, 'script'));
</script-->

<script type="text/javascript">

    var bg_img = $("body").css("background-image");
    var greyBg = document.querySelector("#cinematic");
    if(greyBg){
        greyBg.style.backgroundColor = "#222";

        if (bg_img != 'none') {
            greyBg.style.backgroundColor = "transparent";
        }
        else {
            greyBg.style.backgroundColor = "#222";
        }
    }
</script>

<script type='text/javascript'>
/* <![CDATA[ */
var countVars = {"disqusShortname":"hardcoregamermagazine"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/plugins/disqus-comment-system/public/js/comment_count.js?ver=3.0.17'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var embedVars = {"disqusConfig":{"integration":"wordpress 3.0.17"},"disqusIdentifier":"378445 https:\/\/hardcoregamer.com\/?p=378445","disqusShortname":"hardcoregamermagazine","disqusTitle":"Chex Quest HD Launches for Free on PC","disqusUrl":"https:\/\/hardcoregamer.com\/2020\/05\/18\/chex-quest-hd-launches-for-free-on-pc\/378445\/","postId":"378445"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/plugins/disqus-comment-system/public/js/comment_embed.js?ver=3.0.17'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/plugins/ricg-responsive-images/js/picturefill.min.js?ver=3.0.1'></script>
<script type='text/javascript'>
/* <![CDATA[ */
var author = {"name":"Marcus Estrada"};
/* ]]> */
</script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/google.js?ver=1.0.0'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/navigation.js?ver=20120206'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-content/themes/hardcore-gamer-theme/js/skip-link-focus-fix.js?ver=20130115'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/imagesloaded.min.js?ver=3.2.0'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/masonry.min.js?ver=3.3.2'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/jquery/jquery.masonry.min.js?ver=3.1.2b'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/comment-reply.min.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type='text/javascript' src='https://hardcoregamer.com/wp-includes/js/wp-embed.min.js?ver=24c01401bf29ed77f4ac0a6c60102b5a'></script>
<script type="text/javascript" id="slb_context">/* <![CDATA[ */if ( !!window.jQuery ) {(function($){$(document).ready(function(){if ( !!window.SLB ) { {$.extend(SLB, {"context":["public","user_guest"]});} }})})(jQuery);}/* ]]> */</script>
</body>
</html>